
EXPERIMENT NUMBER 10 

TRANSIENT ANALYSIS USING PLECS 

 

Objectives: 

By completing this experiment, the student is expected to: 

• To be able to use PLECS to simulate transient repose of any passive circuit. 
• To gain understanding on the effects of the damping factor 𝜁 and natural frequency 

𝜔𝑜 on the transient response of a passive circuit. 
• To be able to deliver proper description of any transient response using a set of 

various metrics. 

 

Scope: 

This experiment focusses on the transient analysis of step response of a series 𝑅𝐿𝐶 using 
PLECS; without losing in generality, all the learning objectives can apply to any other formats 
of learning higher order systems. 

 

Experiment structure: 

This experiment consists of a tutorial section and three parts: 

1- The tutorial section is intended to teach the student how to use the PLECS software 
to simulate transient response of passive circuits. 

2- Part-1 will focus on analyzing the effect of the damping factor 𝜁 on the transient 
response of higher order systems. 

3- Part-2 will focus on analyzing the effect of the natural frequency 𝜔𝑜 on the transient 
response of higher order systems. 

4- Part-3 will focus the utilization of various metrics to qualitatively and quantitatively 
describe the transient response of higher order systems. 

 

 

 

 



Background and theory: 

This section is intended to review theoretical aspects related to the topic of the experiment 
only. 

 

 

Figure 1 showcase a step voltage applied to a series 𝑅𝐿𝐶 circuit. A step voltage refers to a 
sudden change in applied voltage to the circuit. This concept is illustrated in Figure 1 using 
voltage source 𝑉𝑠 in series with the switch such that the circuit is initially at rest and at 𝑡 = 0, 
the switch closes, applying the step voltage 𝑉𝑠 across the 𝑅𝐿𝐶 components. This initiates a 
transient response characterized by oscillatory or exponential behavior. The transient 
response is the part of system's complete response that occurs immediately after a sudden 
change in input (e.g., step input) and usually settles out over time to a final value that is 
referred to as the steady-state value. Figure 2 illustrates how the sudden change in the step 
input (i.e., the red signal) could produce various possible transient responses (i.e., blue, 
green, and purple) that inhibit various oscillations, exponential decay, or overshoot before 
reaching the steady-state value. These various formats of the transient response occur due 
to the changes of the system dynamics that resulted due to changes in the 𝑅𝐿𝐶 circuit. 

Studying the transient response takes significant importance as it (𝑖) characterizes the 
behavior of the system, (𝑖𝑖) determines the stability of the system, and (𝑖𝑖𝑖) is essential for 
controlling the system. Studying the transient response of RLC circuits is crucial in power 
systems (preventing surges and faults), signal processing (designing stable filters and 
amplifiers), and communication systems (ensuring reliable RF transmission). It's essential 
in control systems (servo motors and robotics), power electronics (DC-DC converters and 
inverters), and automotive electronics (ECUs and battery management). Additionally, it 
impacts medical devices like pacemakers and bioelectronic sensors, ensuring smooth 
operation. 

 

Figure 1: Step voltage applied to a series RLC circuit. Figure 2: various formats of transient response. 



The transient response can be characterized theoretically using the fundamentals of circuit 
analysis; for instance, Applying KVL around the loop in Figure 1 for 𝑡 > 0 we get 

𝐿
𝑑𝑖

𝑑𝑡
+ 𝑅𝑖 + 𝑣 = 𝑉𝑠, 

where 𝐿 is the inductance, 𝑅 is the resistance, 𝑖 is the current in the loop, 𝑉𝑠 is the source 
voltage and 𝑣 is the voltage across the capacitor. Here, the current flowing through the 
capacitor (i.e., the current in the loop 𝑖) can be correlated to the voltage across the capacitor 
𝑣 as 
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𝑑𝑣
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where 𝐶 is the capacitance. We can now express the KVL as 
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The previous equation is a second order differential equation. One way to solve it is express 
it a characteristic equation and solve the polynomial. More specifically, the corresponding 
characteristic equation is 

𝑠2 +
𝑅

𝐿
𝑠 +

1

𝐿𝐶
= 0. 

Solving for 𝑠 

𝑠 =
−𝑅 ± √𝑅2 − 4𝐿/𝐶

2𝐿
. 

The parameter 𝑠 can also be described using the damping factor 𝜁 and the natural frequency 
𝜔𝑜 (measured in 𝑟𝑎𝑑/𝑠) as 

𝑠 = −𝜁𝜔𝑜 ± 𝜔𝑜√𝜁2 − 1, 

where  
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2
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1

√𝐿𝐶
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Here, based on the damping factor 𝜁, three formats are possible of the homogeneous 
solution 𝑣ℎ(𝑡) of the response: 

• Case-1: Overdamped (𝜁 > 1): 𝑠 has two real and distinct roots. The transient 
response in this case is 



𝑣ℎ(𝑡) = 𝐴𝑒𝑠1𝑡 + 𝐵𝑒𝑠2𝑡. 
• Case-2: Critically damped (𝜁 = 1): 𝑠 has repeated real root. The transient response in 

this case is 
𝑣ℎ(𝑡) = (𝐴 + 𝐵𝑡)𝑒𝑠𝑡. 

• Case-3: Underdamped (𝜁 < 1): 𝑠 has complex conjugate roots. The transient 
response in this case is 

𝑣ℎ(𝑡) = 𝑒−𝛼𝑡(𝐴 cos(𝑤𝑑𝑡) + 𝐴 sin(𝑤𝑑𝑡)), 
where  

𝛼 =
𝑅

2𝐿
,                           and                           𝜔𝑑 = 𝜔𝑜√1 − 𝜁2. 

The particular solution (i.e., the steady-state solution) describe the response under the 
steady-state (i.e., at 𝑡 = ∞); for all the three cases the particular solution 𝑣𝑝(𝑡) is 

𝑣𝑝(𝑡) = 𝑉𝑠 

The general solution describes the overall transient response such as 

𝑣(𝑡) = 𝑣ℎ(𝑡) + 𝑣𝑝(𝑡) 

Thus, the general transient solution for the three cases is 

• Case-1: Overdamped (𝜁 > 1): 𝑠 has two real and distinct roots. The transient 
response in this case is 

𝑣(𝑡) = 𝐴𝑒𝑠1𝑡 + 𝐵𝑒𝑠2𝑡 + 𝑉𝑠. 
• Case-2: Critically damped (𝜁 = 1): 𝑠 has repeated real root. The transient response in 

this case is 
𝑣(𝑡) = (𝐴 + 𝐵𝑡)𝑒𝑠𝑡 + 𝑉𝑠. 

• Case-3: Underdamped (𝜁 < 1): 𝑠 has complex conjugate roots. The transient 
response in this case is 

𝑣ℎ(𝑡) = 𝑒−𝛼𝑡(𝐴 cos(𝑤𝑑𝑡) + 𝐴 sin(𝑤𝑑𝑡)) + 𝑉𝑠. 
 
 
 
 
 

 

 

 



Tutorial: 

This section is intended to teach the student how to use the PLECS software to simulate 
transient response of passive circuits. This part should not be included in the student 
notebook. 

PLECS (Piecewise Linear Electrical Circuit Simulation) is a fast and efficient simulation 
software for power electronics and electrical systems, available as a standalone tool or 
integrated with MATLAB/Simulink. It features a built-in component library for power 
electronics, supports electrical, thermal, and control modeling, enables real-time 
simulation, and allows co-simulation with Simulink. Additionally, it offers automatic code 
generation for embedded systems, making it a valuable tool for designing and testing power 
converters, motor drives, and grid-connected systems in both research and industry. 

(A) Lunching PLECS 
1- PLECS is not free or open-source software; however, Missouri S&T offers PLECS for 

all its students and staff using AppsAnyWhere. Start this tutorial by lunching 
AppsAnyWhere by visiting this link (https://appsanywhere.mst.edu).  

2- Using AppsAnyWhere main window, type PLECS in the search bar and two versions 
of PLECS will appear. The PLECS Blockset is used if PLECS is intended to be utilized 
with MATLAB while PLECS Standalone is for the direct access of PLECS without 
MATLAB integration. For this experiment, we are using PLECS Standalone; click on 
Lunch to lunch  PLECS Standalone. This step is shown in Figure 3. 

 

Figure 3: Lunching PLECS. 

(B) PLECS interface 

When lunching PLECS for the first time, the Library Browser will show up. The Library 
Browser contains all the components that are to be utilized in the design. These 

https://appsanywhere.mst.edu/


components should be placed in the Model window. The Model window is the workspace 
that allow you to place and connect your model for simulation purposes. Open a new 
model window by clicking file → New Model from the Library Browser. The Model window 
will show up with yellow background. This step is illustrated in Figure 4. Note that you can 
access the Library Browser back from the Model window (i.e., in case if Library Browser 
has been closed) by clicking on Windows → Library Browser from the Model window.  

 

 

 

 

 

 

 

 

 

 

(C) Libraries  

The Library Browser consists of various libraries; each containing components that can 
be utilized to simulate various engineering systems. For this experiment, we are 
interested in the following two libraries: (𝑖) Electrical and (𝑖𝑖) System. The Electrical 
library contains components related to various electrical systems. This library consists 
of various sub-libraries. Out of these sub-libraries, we will be using the (𝑖) Sources, (𝑖𝑖) 
the Passive Components, and (𝑖𝑖𝑖) Meters. The Sources contains various electrical 
powering components, the Passive Components contain electrical circuit components 
that doesn’t require to be power up externally to function, and Meters contain sensors 
that measure electrical voltage and current. The System library on the other hand include 
utility components that allows building and displaying the results.  

For the tutorial part, we are interested in simulating the transient response of the circuit 
in Figure 1. As the figure shows, this circuit consists of a DC power source, a resistor, an 
inductor, and a capacitor all in series. Moreover, the voltage across the capacitor 
denoted 𝑣 in the figure is the output voltage that we seek to simulate transient response 
for.  

Figure 4: PLECS interface 



Start building the circuit in Figure 1 by placing the components in the figure. To do so, drag 
the following components from the library and drop it on the Model window. More 
specifically you need the following components: 

• From Electrical → Sources → Voltage Source DC: this component generates 
constant voltage (DC power source). 

• From Electrical → Passive Components → Resistor: this component represents a 
resistor. 

• From Electrical → Passive Components → Inductor: this component represents an 
inductor. 

• From Electrical → Passive Components → Capacitor: this component represents a 
capacitor. 

• From Electrical → Meters → Voltmeter: this component represents a voltameter. 
• From System → Scope: the scope is a utility component that allows you to plot a 

sensor measured value against time (i.e., similar to the oscilloscope). 

Figure 5 shows the required components on the Model Window with the same order 
described above. 

 

Figure 5: The required components 

 

 



(D) Building the circuit 

Build the circuit by connecting the components as it is connected in Figure 1. For 
connecting the components, note that all the inductor, the capacitor, and the voltameter 
have polarities and should be connected with respect the expected direction of the 
current. The voltameter should be connected in parallel with the capacitor as the output 
voltage to be illustrated is the capacitor voltage 𝑣(𝑡). The voltameter should also be 
connected to the scope to show 𝑣(𝑡) against time similar to an oscilloscope. The correct 
connected circuit should look similar to what is illustrated in Figure 6. 

The next step involves specifying the parameters for each component. To do so, double 
click on each component and insert the value of the parameter.  

• The Voltage Source DC has only one parameter that is the amount of the DC voltage. 
• The resistor has only one parameter that is the amount of resistance. 
• The inductor has two parameters that is the amount of inductance, and the initial 

current stored within the inductance. 
• The capacitor has two parameters that is the amount of capacitance, and the initial 

voltage stored within the capacitance. 
• The voltmeter has no parameters to adjust. 

As for the tutorial part, specify the parameters as you desire. Note that you can use the 
exponential notation to specify your values; for example, 300 𝜇𝐹 is 300𝑒 − 6. 

Figure 6: The connected circuit. 



(E) Simulation Parameters 

Before you start your simulation, you need to adjust the Simulation Parameters. To do so, 
click on Simulation → Simulation Parameters from the Model window. A window will 
show up with various settings related to simulation configuration. We will be changing 
only three parameters of interest; these are: 

• Start time (s): this represents the starting time of the simulation. Keep this value 
on 0 𝑠 unless you want to make special simulation that doesn’t start at 𝑡 = 0 𝑠. 

• Time span (s): this represents the stop time of the simulation (i.e., when the 
simulation stop). Setting this parameter extra small will result an incomplete 
simulation (i.e., simulation ends before showing the full response), while setting 
this parameter extra large will compress the response signal in a way that it is not 
longer readable. For this purpose, the stop time should be specified appropriately. 
One way to do so is to rely on some evaluation metrics. More specifically, the 
settling time will be used for this purpose. The Settling time 𝑡𝑠 is the time required 
for the response of a system to remain within a specified percentage (commonly 
2% or 5%) of its final steady-state value after a disturbance or input change, such 
as a step input. The settling time can be determined as follows:  

𝑡𝑠 ≈
4

𝜁𝜔𝑜
 

Set your span time based on the settling time of your system. 
• Max step size (s): this represents the resolution of your simulation. It is 

recommended to use a very small value for this purpose. A 10−6 𝑠 should be 
sufficient.  

Figure 7 illustrates how to specify your simulation parameters. 

 

 

 

 

 

 

 

Figure 7: Setting the simulation parameters. 



(F) Simulation Start 

Now everything is ready for your simulation. To start your simulation click on Simulation 
→ Start from the Model window. To view your simulation results double click on the 
Scope. These steps are shown in Figure 8. 

 

 

(G) Scope 

Scope will be utilized to display results of your simulation. When double clicking on the 
Scope a window of your response against time will show up. The scope has the following 
features: 

• You can zoom to specific time horizon by clicking the cursor on the start time and 
dragging the cursor horizontally to the end time. 

• You can zoom to specific y-axis horizon (e.g., voltage in this case) by clicking the 
cursor on the start voltage and dragging the cursor vertically to the end voltage. 

• You can undo any changes by clicking on the left arrow icon () tabs menu. 
• You can export the figure in CSV format by clicking File → Export → as CVS → All… 
• You can add another sub-figure to the scope to illustrate two figure on the same 

screen by clicking File → Scope parameters… and then a new window will show 

Figure 8: Start the simulation. 



up; set the Number of plots for how many plots you wish to see at the same scope. 
This step is illustrated in Figure 9. 

 

 

 

 

 

 

 

 

Figure 9: changing the Number of plots. 

Test your understanding by creating a new parallel 𝑅𝐿𝐶 circuit. Use the same exact values 
for the resistor, capacitor and inductor. Replace the Voltage Source DC with a Current 
Source DC. You can find this component in the following library path Electrical → 
Sources → Current Source DC. This component represents a DC current source. Change 
the value of the DC current source to any appropriate value. Connect the results of your 
simulation with to the same exact scope of the series 𝑅𝐿𝐶 circuit. Add caption to each 
circuit by clicking on empty yellow space above each of the two circuits. You might 
change the font size and color of your caption if needed. Your configuration should look 
similar to Figure 10.  Start the simulation and observe the results. 

 

 

 

 

 

 

 

 

 Figure 10: simulating two circuits simultaneously. 



Part-1: Analyzing the effect of the dampening factor 𝜻. 

In this section, you will simulate various circuits with different damping factors 𝜁 and 
observe their effects on the transient response. To ensure a fair comparison, we will keep the 
natural frequency 𝜔₀ constant while varying only the damping factor 𝜁. 

Start by constructing three series RLC circuits powered by a DC power voltage source. Use 
the following parameters in Table 1 for each of the three circuits 

Table 1: part-1 simulation parameters. 

𝑉𝑠 in [𝑉] 𝑅 in [Ω] 𝐿 in [𝑚𝐻] 𝐶 in [𝜇 𝐹] 𝜁 
𝜔𝑜 in 

[𝑟𝑎𝑑/𝑠] 
𝑡𝑠 in [𝑠] 

5 1.0 10.0 100.0 ? ? ? ? ? ? ? ? ? 
5 6.32 10.0 100.0 ? ? ? ? ? ? ? ? ? 
5 12.0 10.0 100.0 ? ? ? ? ? ? ? ? ? 

 

For each of the three circuits, calculate damping factor 𝜁, the natural frequency 𝜔₀ and the 
settling time 𝑡𝑠. Add caption of these missing values on the top of each corresponding 
circuit. Connect the output voltage (i.e., voltage across the capacitor) of the three circuits for 
a single scope. Your circuit should look similar to Figure 11. Set the Time span of your 
simulation to be the maximum settling time of the three circuits (i.e., 𝑡𝑠𝑡𝑜𝑝 =

max(𝑡𝑠,1, 𝑡𝑠,2, 𝑡𝑠,3). Run the simulation and observe the results. 

 

 

 

 

 

 

 

 

 

 

 Figure 11: Part-1 simulation circuits. 



In your notebook report include the following: 

1- Include a screenshot of the constructed three circuits. Make sure that the correct 
damping factor, natural frequency and settling time are captioned appropriately and 
clearly on the top of each constructed circuit in your screenshot. 

2- Include the transient responses of the three circuits obtained from the scope. Make 
sure that your figure(s) is high-quality with readable axes and features. You might 
need to export the data as CSV and re-plot the reposes for higher quality if needed. 

3- What type of response does each of the transient responses represent and why? 
Correlate your answer with your theoretical understanding. 

4- Qualitatively describe how each of the three transient responses look like.  
5- For the series 𝑅𝐿𝐶 circuits that you have constructed, what circuit parameter would 

you change to change the response type and why? Correlate your answer with your 
theoretical understanding. 

6- Give your final conclusion; what is the effect of changing the damping factor 𝜁 on your 
transient response? 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 



 

Part-2: Analyzing the effect of the natural frequency 𝝎𝒐 

In this section, you will simulate various circuits with different natural frequencies 𝜔𝑜 and 
observe their effects on the transient response. To ensure a fair comparison, we will keep the 
damping factor 𝜁 constant while varying only the natural frequency 𝜔₀. 

Start by constructing three series RLC circuits powered by a DC power voltage source. Use 
the following parameters in Table 2 for each of the three circuits 

Table 2: part-2 simulation parameters. 

𝑉𝑠 in [𝑉] 𝑅 in [Ω] 𝐿 in [𝑚𝐻] 𝐶 in [𝜇 𝐹] 𝜁 
𝜔𝑜 in 

[𝑟𝑎𝑑/𝑠] 
𝑡𝑠 in [𝑠] 

5 1.0 5.0 50.0 ? ? ? ? ? ? ? ? ? 
5 1.0 7.0 70.0 ? ? ? ? ? ? ? ? ? 
5 1.0 10.0 100.0 ? ? ? ? ? ? ? ? ? 

For each of the three circuits, calculate damping factor 𝜁, the natural frequency 𝜔₀ and the 
settling time 𝑡𝑠. Add caption of these missing values on the top of each corresponding 
circuit. Connect the output voltage (i.e., voltage across the capacitor) of the three circuits for 
a single scope. Your circuit should look similar to Figure 11. Set the Time span of your 
simulation to be the maximum settling time of the three circuits (i.e., 𝑡𝑠𝑡𝑜𝑝 =

max(𝑡𝑠,1, 𝑡𝑠,2, 𝑡𝑠,3). Run the simulation and observe the results. 

In your notebook report include the following: 

1- Include a screenshot of the constructed three circuits. Make sure that the correct 
damping factor, natural frequency and settling time are captioned appropriately and 
clearly on the top of each constructed circuit in your screenshot. 

2- Include the transient responses of the three circuits obtained from the scope. Make 
sure that your figure(s) is high-quality with readable axes and features. You might 
need to export the data as CSV and re-plot the reposes for higher quality if needed. 

3- What type of response does each of the transient responses represent? Did you get 
similar types of responses or different and why? Correlate your answer with your 
theoretical understanding. 

4- Qualitatively describe how each of the three transient responses look like.  
5- For the series 𝑅𝐿𝐶 circuits that you have constructed, what circuit parameter would 

you change to change the response type and why? Correlate your answer with your 
theoretical understanding. 

6- Give your final conclusion; what is the effect of changing the natural frequency 𝜔𝑜 on 
your transient response? 



Part-3: Transient Response Evaluation 

You can qualitatively and quantitatively describe the transient response of any system using 
various of metrics. The following are definitions of some of these metrics: 

• Settling Time 𝑡𝑠: The time required for the response to stay within a certain percentage 
(commonly 2% or 5%) of its final value. The settling time is defined as 

𝑡𝑠 ≈
4

𝜁𝜔𝑜
 

• Peak Time 𝑡𝑝: The time at which the system response reaches its maximum (peak) 
value. 

𝑡𝑝 =
𝜋

𝜔𝑑
 

• Rise Time 𝑡𝑟: The time taken for the response to rise from 10% to 90% of its final value. 

𝑡𝑟 ≈
1.8

𝑤𝑛
 

• Maximum overshoot 𝑀𝑝 (in percentage %): The amount by which the response 
exceeds the final steady-state value, expressed as a percentage. 

𝑀𝑝 = 𝑒
(

𝜁𝜋

√1−𝜁2
)

× 100% 

• Steady-State Error 𝑒𝑠𝑠: The difference between the final output and the desired value. 

Now construct the circuit that is shown in Figure 12. Use the parameters in Table 3. 

Table 3: parameters for part-3 simulation circuits. 

 𝑅1 in [Ω] 𝑅2 in [Ω] 𝐿 in [mH] 𝐶 in [μF] 𝑉𝐷𝐶 in [𝑉] 
Time span 

in [𝑚𝑠] 
Value 30 100 30 10 10 20 

 

 

 

Figure 12: Part-3 simulation circuits. 



In your notebook report include the following: 

1- Include the transient responses of the three circuits obtained from the scope. Make 
sure that your figure(s) is high-quality with readable axes and features. You might 
need to export the data as CSV and re-plot the reposes for higher quality if needed. 

2- What type of response did you get and why?  
3- Use the resulted response plot to find the settling time 𝑡𝑠, peak time 𝑡𝑝, rise time 𝑡𝑟, 

maximum overshoot 𝑀𝑝, and steady-state error 𝑒𝑠𝑠.  
4- Estimate the damping factor and natural frequency using the parameters your 

collected from the previous part. Does this match the response type you have 
predicated? 

5- Critique the obtained response based on the parameters you found. What is wrong in 
this response?  


